Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: My rage with "Rage"

  1. #1
    aka sR.:.Glenn largecanadian's Avatar
    Join Date
    Apr 2007
    Location
    Near Traverse City, MI
    Posts
    399

    My rage with "Rage"

    I was really hoping the patch that was released today would fix my issues, but no, it has not. I've tried EVERY fix out there (catalyst settings, custom .cfg, custom launch options) I've tried 4 different drivers (11.9, 11.10 beta for BF3, the rage fix drivers, and the newest 11.10 with both BF3 and Rage fixes). The new patch hit today and I was hoping my issues were gone, but nope, still the EXACT same. I get into the game, watch the opening video, then once I hit actual rendered stuff I'm getting less than 1fps....Honestly I wouldn't mind a few texture issues if I could actually get into the game.

    My system specs are in my sig


    Guess I'm going to have to reformat and reinstall Windows just to get Rage working?



    Gamer
    -
    PhenomX3 720BE @3.5ghz, 4gb XMS2, Biostar785GE, HIS HD5830, 1TB Samsung F3 7200rpm sata2, 630watt PSU

  2. #2
    Germany [DE]
    UI
    UI is offline
    not quite useless. UI's Avatar
    Join Date
    Oct 2006
    Location
    Here.
    Posts
    14,928

    Re: My rage with "Rage"

    That sucks dude. I actually canceled my preorder for it Tuesday and got Deus ex instead. Ive seen nothing but issues with the PC version as well. I guess that's what happens when you make your game around consoles.

  3. #3
    MisterX's Avatar
    Join Date
    Dec 2010
    Location
    Scotland
    Posts
    2,198

    Re: My rage with "Rage"

    It was very glitchy for me on launch, the "Rage" specific ATI drivers fixed a bunch of the problems but still occasional texture problems and tearing .

    Todays patch... wow super slick and smooth. Turning up the Texture allocation an so on have sorted it all out.

    Love the game, its pure fun to play

  4. #4
    ಠ_ಠ panic!'s Avatar
    Join Date
    Jun 2006
    Location
    Winston-Salem
    Posts
    3,228

    Re: My rage with "Rage"

    I've had a slight texture issue if I rotate my mouse very quickly. Other than that the game runs perfect. I'm actually really enjoying it.
    Quote Originally Posted by Craig View Post
    denny, i didn't know your cadillac had crank windows.

  5. #5
    Quit Rage1's Avatar
    Join Date
    Feb 2007
    Location
    NY state
    Posts
    2,577

    Re: My rage with "Rage"

    same here runs great just a texture popping issue. My biggest bitch is the game is way to short.

  6. #6
    Time 2 Play DigitalDD's Avatar
    Join Date
    May 2003
    Location
    The Land of OZ
    Posts
    6,659

    Re: My rage with "Rage"

    Weren't the recommended specs a Quad core CPU and Nvidia 5xx series or Radeon 58xx/6xxx? Must admit its looks great but it seems like the textures take an extra second or so to kick in on just about every system out there, including the consoles.

    Nice little note on kokatu: Why Was The PC Launch of Rage Such A "Cluster!@#$"?

  7. #7
    aka sR.:.Glenn largecanadian's Avatar
    Join Date
    Apr 2007
    Location
    Near Traverse City, MI
    Posts
    399

    Re: My rage with "Rage"

    Quote Originally Posted by DigitalDD View Post
    Weren't the recommended specs a Quad core CPU and Nvidia 5xx series or Radeon 58xx/6xxx? Must admit its looks great but it seems like the textures take an extra second or so to kick in on just about every system out there, including the consoles.

    Nice little note on kokatu: Why Was The PC Launch of Rage Such A "Cluster!@#$"?
    System Req. Pulled off of bethblog.com (minimum is same listed on the back of the box, I bought a DVD copy)
    Minimum:

    OS: Win XP SP3, Vista, Win 7
    Processor: Intel Core 2 Duo or Equivalent AMD
    Memory: 2GB
    Hard Disk Space: 25GB
    Video Card: GeForce 8800, Radeon HD 4200

    Recommended:

    OS: Win XP SP3, Vista, Win 7
    Processor: Intel Core 2 Quad or Equivalent AMD
    Memory: 4GB
    Hard Disk Space: 25GB
    Video Card: GeForce 9800 GTX, ATI Radeon HD 5550

    At the level my X3 is overclocked and my 1GB DDR5 HD5830 I should have no issues running it at at least medium-high settings...tried a few more tweaks I found online today, still around 0.3fps at any settings



    Gamer
    -
    PhenomX3 720BE @3.5ghz, 4gb XMS2, Biostar785GE, HIS HD5830, 1TB Samsung F3 7200rpm sata2, 630watt PSU

  8. #8
    Nothing Special Demoralized's Avatar
    Join Date
    Oct 2007
    Location
    Alberta
    Posts
    1,291

    Re: My rage with "Rage"

    Applied a few fixes and it ran super smooth. Loved it but it was too short. I've reloaded my save game and went back to do job boards, Mutant Bash, etc...
    Never look down on anybody unless you're helping him up. -
    Jesse Jackson
    -----------------------

    Quote Originally Posted by DennyCrane View Post
    You, sir, are a god damn idiot.
    Love, Denny.

  9. #9
    Time 2 Play DigitalDD's Avatar
    Join Date
    May 2003
    Location
    The Land of OZ
    Posts
    6,659

    Re: My rage with "Rage"

    Quote Originally Posted by largecanadian View Post
    System Req. Pulled off of bethblog.com (minimum is same listed on the back of the box, I bought a DVD copy)
    Minimum:

    OS: Win XP SP3, Vista, Win 7
    Processor: Intel Core 2 Duo or Equivalent AMD
    Memory: 2GB
    Hard Disk Space: 25GB
    Video Card: GeForce 8800, Radeon HD 4200

    Recommended:

    OS: Win XP SP3, Vista, Win 7
    Processor: Intel Core 2 Quad or Equivalent AMD
    Memory: 4GB
    Hard Disk Space: 25GB
    Video Card: GeForce 9800 GTX, ATI Radeon HD 5550

    At the level my X3 is overclocked and my 1GB DDR5 HD5830 I should have no issues running it at at least medium-high settings...tried a few more tweaks I found online today, still around 0.3fps at any settings
    You tried the low settings with all the eye candy turned off? Then gradually add stuff till it craps out again, then maybe you can play it a bit. Just a thought, that kept me from upgrading an aging system a few times.

  10. #10
    ಠ_ಠ panic!'s Avatar
    Join Date
    Jun 2006
    Location
    Winston-Salem
    Posts
    3,228

    Re: My rage with "Rage"

    Everyone I know with an ATI card is having major issues with it.
    Quote Originally Posted by Craig View Post
    denny, i didn't know your cadillac had crank windows.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Advertise:
Ads@StrafeRight.com

Terms of Service || Privacy & DMCA Policies || About Us
Powered by vBulletin® Version 4.2.2
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.0

All times are GMT -4. The time now is 10:29 AM.
Design by DanFortH